Notebookfestplatte einbauen leicht gemacht

Da mir meine 40GB HD in meinem IBM Notebook nicht mehr reicht, habe ich mich endlich dazu durchgerungen einen neue einzubauen. Also habe ich mir eine 100 GB Seagate-HD bestellt. Gestern kam das heiß ersehnte Teil auch endlich bei mir an und ich war bis dahin überzeugt, dass das ja wohl flott erledigt ist. Also packe ich mein Imaging-Tool aus (Norton Ghost Personal 9.0) und dupliziere die aktuelle HD auf die neue, die ich in ein USB-Gehäuse eingebaut und per USB mit dem IBM verbunden habe. Die Duplizierung war schnell und ohne Fehler erledigt. So, schnell die alte lahme HD raus und die neue rein. Der Umbau war in wenigen Minuten erledigt und es geht an den Neustart. Doch dann passierts, da taucht nur noch das Wort GRUB auf dem Bildschirm auf und mehr nicht. Dazu muss ich sagen, dass auf der alten HD Windows und Linux parallel liefen und per GRUB gebootet wurde. Doch scheinbar ist da beim Duplizieren ein „kleiner Fehler“ passiert. Ich dachte mir also kein Problem, wahrscheinlich ein typisches Problem mit dem MBR (Master Boot Record), das kennt man ja, wenn man schon mal mit verschiedenen Installationen rumgespielt hat. Also die Windows-CD rein und im Reperaturmodus gebootet. Auf der Kommandozeile dann das Kommando fixmbr abgesetzt, neu gebootet und … nix. Verdammt, was iss da wohl schief gegangen. Also hab ich mal von den Analysetools des Ghost-Pakets gebootet und den Bootsektor untersucht. Was ich da feststellte machte mich doch etwas nervös, denn angeblich war der Startsektor der HD auf 150 verschoben und da dieser nicht mehr bei 0 lag, wollte weder Ghost noch Partition Magic was an dieser HD ändern. Auch fdisk konnte mit dieser Platte nichts mehr anfangen. Nach der Abschätzung der Möglichkeiten die mir nun noch blieben, entschied ich mich für eine Linux-Live-CD und bootete die Auditor-Live-CD. Dort ist das Tool cfdisk installiert und tatsächlich, dieses Tool zeigte mir zumindest mal wieder die HD-Struktur an. Also, alle Partitionen löschen und eine neue mit fat32-Format anlegen. Alles funktioniert ohne Probleme. Danach ein Check mit Partition Magic und endlich konnte ich alle Partitionen ansprechen und umpartitionieren. Da ich noch ein Image meiner Windows-Partition auf Lager hatte, spielte ich dieses ein und bootete erneut. Doch nun bootet der Rechner plötzlich von PXE, also vom Netzwerk aus. Da passt also wohl der MBR noch nicht. Ein Start von Boot Magic half dann hier noch nach und setzte den korrekten MBR. Beim nächsten Neustart lief dann das ganze System ohne Probleme und ich konnte endlich wieder mit einem funktionierenden System arbeiten. Zum guten Schluss kann ich also nur noch empfehlen, dupliziere keine HD auf eine andere, wenn die Partitions- und HD-Größen nicht genau aufeinander passen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Time limit is exhausted. Please reload CAPTCHA.